• Home
  • Documentation
  • Common Questions
  • I use PHP 8 and I get: Fatal error Declaration of igalleryController

On November 26 2020 a major new version of PHP was released, version 8. If you use version 4.4 of Ignite Gallery or below, and use PHP8, you will get an error like this:

Fatal error: Declaration of igalleryControllerProfiles::getModel must be compatible with....

Version 4.5 of Ignite Gallery works with PHP8. You can install version 4.5 on top of any 4.x or 3.x gallery version.

If you do not want to upgrade the gallery, please go to your webhosting control panel, and choose to use PHP 7 as your version.